Aucun son dans TES: Arena sous DOSBox

Puisque c'est ma première entreprise impliquant une installation manuelle de DOSBox, je ne sais pas si le problème est avec l'installation de DOSBox elle-même ou avec le jeu. Quoi qu'il en soit, je ne semble actuellement pas avoir de son ou de musique en jouant The Elder Scrolls: Arena sous DOSBox sur mon ordinateur portable.

Toute la séquence d'introduction est silencieuse, jusqu'à l'écran de sélection des statistiques. Je ne l'ai pas encore testé, mais j'aurais vraiment espéré entendre quelque chose maintenant si cela fonctionnait.

Je suis certain que j'ai couvert toutes les spécifications système pertinentes ci-dessous. Y a-t-il quelque chose de mal configuré ici, que je manque? Ou le problème est-il plus grave que cela? Quels utilitaires ou méthodes sont disponibles pour aider à résoudre ce problème?

De plus, je suis conscient qu'il existe une version pré-emballée 1.07 disponible. Cependant, j'aimerais essayer de faire fonctionner celui-ci pendant un certain temps avant de mettre à niveau.

Configuration du système:

  • OS: Windows 7 x64 SP1
  • Version DOSBox: 0.74
  • TES Arena Version: 1.06 (téléchargé depuis http://www.elderscrolls.com/arena )
  • Pilotes audio du système hôte:
    • Dispositif audio haute définition AMD
    • SoundMAX Integrated Digital HD Audio
  • Configuration du son du système invité:
[midi] mpu401=intelligent mididevice=default midiconfig= [sblaster] sbtype=sb16 sbbase=220 irq=7 dma=1 hdma=5 sbmixer=true oplmode=auto oplemu=default oplrate=44100 [gus] gus=false gusrate=44100 gusbase=240 gusirq=5 gusdma=3 ultradir=C:\ULTRASND [speaker] pcspeaker=true pcrate=44100 tandy=auto tandyrate=44100 disney=true 
  • Guest System AUTOEXEC:
 [autoexec] @echo off MOUNT CD:\DOSBox\Root\ CLS CD \Games\TESArena A.EXE 
  • Configuration sonore dans INSTALL pour TES: Arena:
 SOUND: Sound Blaster or SB16 (or compatible) - IO:220 IRQ:7 DMA:1 MUSIC: Sound Blaster or SB16 (or compatible) - IO:220 IRQ:7 DMA:1 

TL; DR: Assurez-vous d'exécuter ARENA.BAT pour lancer le jeu.


Cela s'est avéré être un tel problème RTFM, je veux presque me tirer dessus.

Tout au long de l'installation et de l'exécution du jeu, j'avais réglé les instructions de Bethesda un peu pour convenir à mon système de configuration préféré et pour résoudre certains problèmes que j'ai rencontrés. Après avoir rencontré un problème dans l'étape où il me dit d'exécuter INSTALL.EXE sur la machine hôte , (qui échouera sur un système x64 – donc, vous devez l'exécuter à partir de DOSBox) J'ai commis l'erreur de commencer à penser que je Était plus intelligent que Bethesda.

Donc, quand est-il arrivé l'heure d'exécuter C:\Arena\Arena j'ai plutôt exécuté dir C:\Games\TESArena\*.exe pour voir s'il y avait même un fichier exécutable Arena dans mon dossier d'installation personnalisé pour le jeu. À ce stade, le plus proche de l'arène que j'ai vu était A.EXE . Je ne me suis pas rendu compte à l'époque que le manuel faisait référence à un Arena.BAT , qui est un fichier batch qui exécute A.EXE et passe les paramètres pour configurer les périphériques audio comme choisis dans INSTALL.EXE . Donc, bien sûr, le jeu fonctionnera si vous exécutez directement A.EXE – il ne saura plus comment (et, par conséquent, ne sera pas) gérer le son.